General Board

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Looking for a couple XS 650 Special items
sgtsteve 2 547 by jetmechmarty
Aug 10, 2017 20:19:10 GMT -5
Thread  
newBookmarkLockedFalling XS 650 handlebars.
ausmark 2 402 by ausmark
Jun 18, 2017 10:25:04 GMT -5
Thread  
newBookmarkLockedFalling bolt size for sump fiilter and sump coverplate
lidirtrider 0 307 by lidirtrider
May 3, 2017 19:00:22 GMT -5
Thread  
newBookmarkLockedFalling Departing Xs unitsand other observstions
motormike 0 325 by motormike
Apr 12, 2017 19:57:55 GMT -5
Thread  
newBookmarkLockedFalling XS650 Firing Issue
dltowers 1 337 by grizld1
Dec 19, 2016 9:27:24 GMT -5
Thread  
newBookmarkLockedFalling FYI Mag Review
motormike 0 237 by motormike
Sept 19, 2016 18:45:30 GMT -5
Thread  
newBookmarkLockedFalling Where are they ?
motormike 11 548 by motormike
Aug 28, 2016 10:23:13 GMT -5
Thread  
newBookmarkLockedFalling Help needed, UK market parts list.
madmax 1 238 by crb999
Jul 12, 2016 5:23:19 GMT -5
Thread  
newBookmarkLockedFalling Rear number plate
crb999 2 210 by crb999
Jul 12, 2016 5:14:16 GMT -5
Thread  
newBookmarkLockedFalling KCFD
ignitionsystem 2 401 by ignitionsystem
Nov 27, 2015 9:43:23 GMT -5
Thread  
newBookmarkLockedFalling HAPPY THANKSGIVING !
motormike 1 220 by preston
Nov 25, 2015 10:41:48 GMT -5
Thread  
newBookmarkLockedFalling Meet the 84 mpg car that literally pays for itself
kaleylewis 3 497 by 5twins
Apr 15, 2015 11:31:07 GMT -5
Thread  
newBookmarkLockedFalling XS650 vs
terribletabo1 1 644 by ignitionsystem
Mar 1, 2015 18:45:51 GMT -5
Thread  
newBookmarkLockedFalling just a phase . .
Burns 0 466 by Burns
Feb 23, 2015 18:04:11 GMT -5
Thread  
newBookmarkLockedFalling Rust bustin'
Chuckwagon 3 764 by motormike
Jan 22, 2015 10:22:52 GMT -5
Thread  
newBookmarkLockedFalling Stolen XS650
primus 2 629 by primus
May 23, 2014 20:40:18 GMT -5
Thread  
newBookmarkLockedFalling Looking back/looking forward
Burns 4 534 by Burns
May 2, 2014 17:29:09 GMT -5
Thread  
newBookmarkLockedFalling Help me identify the year of this gas tank
mahanlee 11 1,224 by mahanlee
Apr 18, 2014 9:13:45 GMT -5
Thread  
newBookmarkLockedFalling Leslie's Brit style tracker
Pages:
leslie 39 2,397 by leslie
Mar 26, 2014 14:21:26 GMT -5
Thread  
newBookmarkLockedFalling help with a bad choice
86304 2 623 by 86304
Feb 13, 2014 16:09:40 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
General Board
You can talk about anything here
Board Statistics
Threads and Posts
Total Threads:2,530
Total Posts:15,252
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5