General Board

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling John Underwood
ignitionsystem 2 840 by grizld1
Mar 28, 2013 9:40:46 GMT -5
Thread  
newBookmarkLockedFalling Special framed road racers
Burns 2 696 by Burns
Mar 21, 2013 22:35:42 GMT -5
Thread  
newBookmarkLockedFalling The Future ?
motormike 1 444 by Burns
Mar 17, 2013 17:00:47 GMT -5
Thread  
newBookmarkLockedFalling paperless frames in CA
beekay 0 433 by beekay
Feb 16, 2013 11:24:27 GMT -5
Thread  
newBookmarkLockedFalling Road Conditions
10ecjed 0 476 by 10ecjed
Jan 15, 2013 10:10:31 GMT -5
Thread  
newBookmarkLockedFalling DOWN UNDER !
motormike 0 455 by motormike
Dec 13, 2012 19:04:35 GMT -5
Thread  
newBookmarkLockedFalling Where Is Everyone
Pages:
slide 20 1,987 by wideload
Dec 9, 2012 18:07:09 GMT -5
Thread  
newBookmarkLockedFalling Today
preston 0 422 by preston
Nov 22, 2012 17:55:05 GMT -5
Thread  
newBookmarkLockedFalling BeeMer Auf ver der zane
motormike 2 828 by orforester
Nov 18, 2012 22:16:38 GMT -5
Thread  
newBookmarkLockedFalling 1977 Emblems or stickers?
roto36 1 593 by preston
Nov 18, 2012 22:14:15 GMT -5
Thread  
newBookmarkLockedFalling Virago 920
Pages:
grepper 24 4,279 by pursang
Oct 25, 2012 20:29:37 GMT -5
Thread  
newBookmarkLockedFalling Engine videos
Machi 0 424 by Machi
Oct 25, 2012 19:56:53 GMT -5
Thread  
newBookmarkLockedFalling WANTED: Video/sound clips of Cone exhaust parts
coneeng 0 414 by coneeng
Oct 23, 2012 11:20:16 GMT -5
Thread  
newBookmarkLockedFalling Battery
slide 0 555 by slide
Oct 21, 2012 8:58:00 GMT -5
Thread  
newBookmarkLockedFalling Nuts on the road
10ecjed 4 680 by tomterrific
Oct 16, 2012 9:29:56 GMT -5
Thread  
newBookmarkLockedFalling Old Article: STEVE McQUEEN ’66 POPULAR SCIENCE | W
terribletabo1 0 529 by terribletabo1
Oct 9, 2012 0:46:04 GMT -5
Thread  
newBookmarkLockedFalling Buyer Beware - new name/old ways
Burns 1 632 by rebelron
Sept 24, 2012 12:55:29 GMT -5
Thread  
newBookmarkLockedFalling Warning: MikesXS Banjo Bolts!
primus 0 636 by primus
Aug 23, 2012 15:24:25 GMT -5
Thread  
newBookmarkLockedFalling CA Title
tonyc2me 0 398 by tonyc2me
Jul 18, 2012 13:55:22 GMT -5
Thread  
newBookmarkLockedFalling Camshaft seal oil ring gasket
Pages:
Burns 26 1,722 by Burns
Jul 15, 2012 23:08:14 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
General Board
You can talk about anything here
Board Statistics
Threads and Posts
Total Threads:2,530
Total Posts:15,252
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5