Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling 650motorcycles.com
jack 7 1,725 by sportydriver
Jun 10, 2007 15:56:00 GMT -5
Thread  
newBookmarkLockedFalling Classic Bike magazine XS 650
breezy 0 1,033 by breezy
May 20, 2007 11:43:51 GMT -5
Thread  
newBookmarkLockedFalling Tony Hall has passed away.
gdjohnson 10 5,288 by crystalmeth04
Mar 20, 2007 13:31:30 GMT -5
Thread  
newBookmarkLockedFalling I'm Back (again!!!)
crazypj22 6 907 by crazypj22
Mar 27, 2006 2:38:45 GMT -5
Thread  
newBookmarkLockedFalling new upload pic tool
jeepurze 0 628 by jeepurze
Mar 1, 2006 20:50:11 GMT -5
Thread  
newBookmarkLockedFalling Attn. So.Cal. Owners!
Wahoo650 0 631 by Wahoo650
Feb 15, 2006 9:43:22 GMT -5
Thread  
newBookmarkLockedFalling 50 state epa regs for bikes!!!!!!!!!!
jeepurze 11 1,031 by 650mike
Oct 10, 2005 23:35:14 GMT -5
Thread  
newBookmarkLockedFalling Where is the "Members Rides" section ?????
lilbill 2 678 by lilbill
Jun 28, 2005 21:52:39 GMT -5
Thread  
newBookmarkLockedFalling ProBoards V4 Upgrade comming!
Bob Dammit 0 520 by Bob Dammit
Mar 21, 2005 18:26:16 GMT -5
Thread  
newBookmarkLockedFalling UPDATE YOUR BOOKMARKS!
Bob Dammit 0 548 by Bob Dammit
Feb 10, 2005 22:14:38 GMT -5
Thread  
newBookmarkLockedFalling New Chat Room Up and Running!
Bob Dammit 0 563 by Bob Dammit
Jan 24, 2005 20:17:04 GMT -5
Thread  
newBookmarkLockedFalling More Additions to the board
Bob Dammit 0 415 by Bob Dammit
Jan 6, 2005 22:14:47 GMT -5
Thread  
newBookmarkLockedFalling IMPORTANT!!!
Bob Dammit 2 811 by Bob Dammit
Dec 31, 2004 20:53:09 GMT -5
Thread  
newBookmarkLockedFalling I will be Returning!
Bob Dammit 4 626 by burned
Aug 23, 2004 8:06:25 GMT -5
Thread  
newBookmarkLockedFalling Looking for help with the Board
Bob Dammit 0 505 by Bob Dammit
Jun 24, 2004 22:43:32 GMT -5
Thread  
newBookmarkLockedFalling Members and Technical Advisor
Pages:
Six-Five-O 15 1,624 by Six-Five-O
Jun 7, 2004 13:58:37 GMT -5
Thread  
newBookmarkLockedFalling Board News
Hammerin 2 615 by Six-Five-O
Apr 20, 2004 10:10:33 GMT -5
Thread  
newBookmarkLockedFalling Senior Archivist
Six-Five-O 4 611 by Hammerin
Apr 4, 2004 0:11:01 GMT -5
Thread  
newBookmarkLockedFalling Let the fun begin.
gdjohnson 6 589 by RYLWLF
Feb 17, 2004 21:26:50 GMT -5
Thread  
newBookmarkLockedFalling Feel free to use the Calendar...
Bob Dammit 2 616 by Bob Dammit
Feb 15, 2004 21:38:34 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
News
Check here for website and Board news
Board Statistics
Threads and Posts
Total Threads:35
Total Posts:327
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5