Stock Bikes

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling please help
firsttimebiker72 0 486 by firsttimebiker72
Oct 11, 2008 12:19:03 GMT -5
Thread  
newBookmarkLockedFalling New guy, new bike
Freak Daddy 2 750 by Freak Daddy
Oct 8, 2008 21:00:21 GMT -5
Thread  
newBookmarkLockedFalling My 1979 Special II
rhilker 0 920 by rhilker
Sept 18, 2008 19:07:15 GMT -5
Thread  
newBookmarkLockedFalling Can anyone help me out
xs650bobber 2 605 by xs650bobber
Sept 5, 2008 16:04:47 GMT -5
Thread  
newBookmarkLockedFalling New edition to the family
shifty 5 886 by superballz
Sept 4, 2008 18:16:04 GMT -5
Thread  
newBookmarkLockedFalling My last project. A TX500
7thxs 0 686 by 7thxs
Aug 23, 2008 1:22:58 GMT -5
Thread  
newBookmarkLockedFalling 1977 XS 650D
Slimbob 3 1,306 by Slimbob
Aug 20, 2008 7:58:31 GMT -5
Thread  
newBookmarkLockedFalling my '81
rickless 14 1,205 by twinfan
Aug 17, 2008 20:53:33 GMT -5
Thread  
newBookmarkLockedFalling My Altered '79 Special
leethal 6 1,954 by leethal
Jul 10, 2008 7:28:35 GMT -5
Thread  
newBookmarkLockedFalling Latest from the Gnomelab
gnomad 3 755 by leethal
Jun 19, 2008 23:50:44 GMT -5
Thread  
newBookmarkLockedFalling Machi's 80 SG
Machi 0 828 by Machi
Jun 7, 2008 22:31:28 GMT -5
Thread  
newBookmarkLockedFalling Freshman project
webbie89 2 725 by webbie89
May 25, 2008 21:25:01 GMT -5
Thread  
newBookmarkLockedFalling My 79 XS
crazyred 6 1,092 by crazyred
May 24, 2008 14:20:01 GMT -5
Thread  
newBookmarkLockedFalling My 'stock' 840's
xs1961 6 1,107 by ignition
May 24, 2008 8:23:50 GMT -5
Thread  
newBookmarkLockedFalling the family
slow rider 10 1,062 by steelburner
May 13, 2008 10:36:07 GMT -5
Thread  
newBookmarkLockedFalling Addicted to the xs650
grepper 12 1,532 by Burns
Apr 24, 2008 9:50:09 GMT -5
Thread  
newBookmarkLockedFalling best picture ever!
nickswan 9 1,826 by davmo
Apr 11, 2008 15:29:55 GMT -5
Thread  
newBookmarkLockedFalling Cant post pic
xs1961 1 443 by xs1961
Apr 8, 2008 2:11:36 GMT -5
Thread  
newBookmarkLockedFalling these bikes are cool
johnb81650 5 1,316 by johnb81650
Mar 3, 2008 20:05:58 GMT -5
Thread  
newBookmarkLockedFalling My 79'
nitromonkey 4 989 by nitromonkey
Feb 29, 2008 13:22:54 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Stock Bikes
Post pics of your stock bikes
Board Statistics
Threads and Posts
Total Threads:157
Total Posts:881
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5