Stock Bikes

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling jflugo's 1974 TX650A
jflugo 14 1,274 by jflugo
Feb 8, 2008 17:06:00 GMT -5
Thread  
newBookmarkLockedFalling My XS650 SG
grepper 1 844 by motormike
Feb 7, 2008 17:50:23 GMT -5
Thread  
newBookmarkLockedFalling I like this , its cool.
jeepurze 3 1,506 by steelburner
Jan 30, 2008 19:05:38 GMT -5
Thread  
newBookmarkLockedFalling My New Bike
2wheelsgood 0 713 by 2wheelsgood
Sept 21, 2007 8:01:16 GMT -5
Thread  
newBookmarkLockedFalling LoneSpar's '81 XS650 Special
lonespar 9 1,165 by lonespar
Sept 4, 2007 15:33:41 GMT -5
Thread  
newBookmarkLockedFalling My 1981 XS650 Special II
dhansen 12 2,105 by hesredbird
Aug 4, 2007 5:36:34 GMT -5
Thread  
newBookmarkLockedFalling My 81 Special's New life
targis34 1 932 by lonespar
Jul 29, 2007 17:10:28 GMT -5
Thread  
newBookmarkLockedFalling XS's 81 XS650H
xsyamahagdr 5 847 by xsyamahagdr
Jul 29, 2007 6:11:40 GMT -5
Thread  
newBookmarkLockedFalling jfinnan's 1981 650 Special
jfinnan 2 1,140 by jfinnan
Jul 21, 2007 9:03:07 GMT -5
Thread  
newBookmarkLockedFalling My 75 project
thumper931 6 1,079 by dhansen
Jul 19, 2007 1:02:44 GMT -5
Thread  
newBookmarkLockedFalling My 1980 XS650G Special II
71XS1B 3 1,345 by 71XS1B
Jun 5, 2007 14:49:48 GMT -5
Thread  
newBookmarkLockedFalling '81 special ready to go!!!
pctxs650 3 849 by damian721
Jun 1, 2007 1:55:34 GMT -5
Thread  
newBookmarkLockedFalling lol...no more i swear
johnb81650 0 792 by johnb81650
May 3, 2007 16:22:26 GMT -5
Thread  
newBookmarkLockedFalling ok last one...lol
johnb81650 0 489 by johnb81650
May 3, 2007 16:18:42 GMT -5
Thread  
newBookmarkLockedFalling my polished ready 2 ride xs
johnb81650 0 888 by johnb81650
May 3, 2007 16:13:11 GMT -5
Thread  
newBookmarkLockedFalling my 71 xs-1 b
bill letson 3 987 by motormike
Feb 10, 2007 17:24:28 GMT -5
Thread  
newBookmarkLockedFalling 77 xs
Nolan 10 1,405 by motormike
Feb 2, 2007 13:45:36 GMT -5
Thread  
newBookmarkLockedFalling one more...for now...lol
johnb81650 3 615 by johnb81650
Jan 26, 2007 8:50:18 GMT -5
Thread  
newBookmarkLockedFalling my ride part 2
johnb81650 2 591 by johnb81650
Jan 26, 2007 8:35:12 GMT -5
Thread  
newBookmarkLockedFalling cant wait for summer
johnb81650 0 486 by johnb81650
Jan 25, 2007 18:05:27 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Stock Bikes
Post pics of your stock bikes
Board Statistics
Threads and Posts
Total Threads:157
Total Posts:881
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5