Stock Bikes

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling just a good cleaning
johnb81650 0 569 by johnb81650
Jan 25, 2007 18:01:56 GMT -5
Thread  
newBookmarkLockedFalling more pics
johnb81650 0 452 by johnb81650
Jan 25, 2007 17:58:43 GMT -5
Thread  
newBookmarkLockedFalling my 81 xs
johnb81650 2 865 by johnb81650
Jan 16, 2007 21:36:26 GMT -5
Thread  
newBookmarkLockedFalling My 1972 XS650
heyjohn 2 1,047 by heyjohn
Jan 16, 2007 21:17:26 GMT -5
Thread  
newBookmarkLockedFalling Steve Knoebber's '83 Special
Knobbs 13 5,004 by ttmaniac
Dec 28, 2006 21:00:58 GMT -5
Thread  
newBookmarkLockedFalling my ride
johnb81650 0 620 by johnb81650
Dec 27, 2006 21:32:12 GMT -5
Thread  
newBookmarkLockedFalling not stock not too custom
myxsownsme 1 885 by myxsownsme
Nov 24, 2006 23:22:19 GMT -5
Thread  
newBookmarkLockedFalling Photos.
mkrusz 0 620 by mkrusz
Oct 11, 2006 12:17:14 GMT -5
Thread  
newBookmarkLockedFalling My 81 stocker
bubbabuck 1 678 by quickstrike
Oct 7, 2006 21:03:41 GMT -5
Thread  
newBookmarkLockedFalling 650 Special Awake after 16 Years!
quickstrike 5 1,004 by quickstrike
Oct 3, 2006 8:02:47 GMT -5
Thread  
newBookmarkLockedFalling Latest Pictures
derbytown 0 672 by derbytown
Aug 23, 2006 0:31:07 GMT -5
Thread  
newBookmarkLockedFalling My Finally-Running-Right 650!
2wheeler 1 567 by rubix
Aug 18, 2006 20:31:53 GMT -5
Thread  
newBookmarkLockedFalling Not so Special Special
crank172 9 1,006 by motormike
Aug 9, 2006 23:02:53 GMT -5
Thread  
newBookmarkLockedFalling My 1975 XS650B with 8000 miles
sylvano 5 750 by Six-Five-O
Jul 23, 2006 22:47:53 GMT -5
Thread  
newBookmarkLockedFalling Hobnob's '81 XS
hobnob 1 713 by otto
Jun 25, 2006 23:29:42 GMT -5
Thread  
newBookmarkLockedFalling 1978 XS650 (WIP)
billxs650se 3 2,029 by billxs650se
Jun 7, 2006 7:47:52 GMT -5
Thread  
newBookmarkLockedFalling 1977 XS400
ilovemountains 3 797 by legacy
May 28, 2006 2:31:06 GMT -5
Thread  
newBookmarkLockedFalling Sweet stock
fixerguy 0 714 by fixerguy
May 19, 2006 22:21:59 GMT -5
Thread  
newBookmarkLockedFalling XS650 Rides the Mountains
bigbatman 1 797 by psssniper
May 2, 2006 20:10:48 GMT -5
Thread  
newBookmarkLockedFalling Bigbatmans first ride
psssniper 2 666 by billxs650se
Apr 24, 2006 14:20:01 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Stock Bikes
Post pics of your stock bikes
Board Statistics
Threads and Posts
Total Threads:157
Total Posts:881
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5