Charging Systems

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling mrriggs bracket
Burns 2 710 by Burns
Jul 21, 2011 17:57:33 GMT -5
Thread  
newBookmarkLockedFalling over charging problem need help
erice1984 3 1,197 by pamcopete
Jul 19, 2011 1:06:37 GMT -5
Thread  
newBookmarkLockedFalling 73 TX650 Charging woes (It was my brushes)
Pages:
xulf13 20 2,011 by xsleo
Jul 10, 2011 10:44:07 GMT -5
Thread  
newBookmarkLockedFalling Mikes rectifier schematic help. 79
garyr 6 1,209 by ShakerNorm
Jul 10, 2011 10:30:00 GMT -5
Thread  
newBookmarkLockedFalling Separate reg/rec, 1978 XS650E - alternator test
Ecotox 4 1,269 by xsleo
Jun 26, 2011 13:04:16 GMT -5
Thread  
newBookmarkLockedFalling Overcharging XS
ecxs 8 2,248 by ecxs
Jun 14, 2011 17:45:39 GMT -5
Thread  
newBookmarkLockedFalling Boyer and the Battery Box
Burns 13 882 by Burns
May 18, 2011 12:57:03 GMT -5
Thread  
newBookmarkLockedFalling dead charging system
sailor 9 1,216 by sailor
May 18, 2011 11:29:13 GMT -5
Thread  
newBookmarkLockedFalling is a stator bad when...
locknload 3 661 by xsleo
May 15, 2011 14:49:40 GMT -5
Thread  
newBookmarkLockedFalling all right smart guys answer me this
Pages:
locknload 21 1,826 by jeffnfranklintn
May 11, 2011 15:08:28 GMT -5
Thread  
newBookmarkLockedFalling Alternator questions
weaselbeak 0 751 by weaselbeak
Apr 26, 2011 0:08:28 GMT -5
Thread  
newBookmarkLockedFalling No brushes, did I wreck things?
josh6990 4 914 by aldo5468
Apr 7, 2011 21:07:40 GMT -5
Thread  
newBookmarkLockedFalling Eating Batt
thejoebobbiggs 7 934 by thejoebobbiggs
Apr 6, 2011 21:17:19 GMT -5
Thread  
newBookmarkLockedFalling Boyer vs. Pamco
jossh77 9 1,854 by pamcopete
Mar 21, 2011 7:15:53 GMT -5
Thread  
newBookmarkLockedFalling Help. basic wiring
nickyc 13 1,785 by ShakerNorm
Mar 16, 2011 7:43:47 GMT -5
Thread  
newBookmarkLockedFalling reg/rec in the starter location
ohioninja 3 1,018 by ohioninja
Mar 9, 2011 15:40:59 GMT -5
Thread  
newBookmarkLockedFalling HARBOR FREIGHT BATTERY TENDERS
sonnydaze 14 6,280 by cros36
Mar 7, 2011 14:47:06 GMT -5
Thread  
newBookmarkLockedFalling permanent magnet
jefferytodd 4 1,175 by grepper
Mar 7, 2011 11:54:45 GMT -5
Thread  
newBookmarkLockedFalling Charging at 15v... Chrysler reg/ radio shack rec.
Pages:
yamahachop 18 2,371 by pamcopete
Mar 4, 2011 7:15:38 GMT -5
Thread  
newBookmarkLockedFalling Voltage irregularity
slow rider 9 975 by pamcopete
Feb 28, 2011 7:43:28 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Charging Systems
Charging problems and solutions including battery, alternator and related wiring.
Board Statistics
Threads and Posts
Total Threads:669
Total Posts:5,114
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5