Trouble Shooting

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling 81 xs650 special sputters below 3000 rpm
vintagerider81 1 973 by jetmechmarty
Jan 31, 2014 21:50:42 GMT -5
Thread  
newBookmarkLockedFalling Using oil - blowing through the exhaust
Pages:
ash13brook 21 1,897 by grizld1
Oct 5, 2013 11:05:35 GMT -5
Thread  
newBookmarkLockedFalling Anyone near Klamath Falls, OR?
powershouse 0 604 by powershouse
Sept 9, 2013 16:35:31 GMT -5
Thread  
newBookmarkLockedFalling Rear brake bleeding problem
Pages:
claytonia 17 1,849 by claytonia
Jul 15, 2013 8:57:45 GMT -5
Thread  
newBookmarkLockedFalling Need some help
kscustom 1 862 by grizld1
Jun 25, 2013 23:22:43 GMT -5
Thread  
newBookmarkLockedFalling jump out of first
pablosixfivezero 2 902 by xsleo
May 30, 2013 15:20:34 GMT -5
Thread  
newBookmarkLockedFalling Weird issue - No revs!
Pages:
limeybikes 16 1,798 by 10ecjed
May 23, 2013 7:07:30 GMT -5
Thread  
newBookmarkLockedFalling Fork Copper washer?
hardwood 3 791 by 5twins
Mar 4, 2013 11:54:51 GMT -5
Thread  
newBookmarkLockedFalling is my timing off?
dlandhooligan 10 1,510 by grizld1
Jan 17, 2013 13:13:05 GMT -5
Thread  
newBookmarkLockedFalling stuck front caliper
jjander 4 1,067 by jetmechmarty
Dec 3, 2012 1:49:42 GMT -5
Thread  
newBookmarkLockedFalling Part cracked (don't know name), needs replacing?
rezajan 4 1,021 by tomterrific
Nov 2, 2012 9:10:31 GMT -5
Thread  
newBookmarkLockedFalling Valve adj. then no start.
brewerfan 4 1,319 by brewerfan
Jul 1, 2012 18:45:37 GMT -5
Thread  
newBookmarkLockedFalling XS650 won't start - no spark!
robjack007 4 3,576 by ShakerNorm
Jun 26, 2012 20:03:47 GMT -5
Thread  
newBookmarkLockedFalling RPM problems not returning to idle
dpmulvan 5 922 by 5twins
Jun 13, 2012 18:10:41 GMT -5
Thread  
newBookmarkLockedFalling 81 xs650 special strange issue
vintagerider81 8 1,136 by vintagerider81
Jun 11, 2012 20:54:36 GMT -5
Thread  
newBookmarkLockedFalling 1st start of season / no headlight
snydermr2 10 1,023 by speez
Mar 24, 2012 8:30:32 GMT -5
Thread  
newBookmarkLockedFalling only runing on one cylinder
jakemann 12 1,177 by xsleo
Feb 23, 2012 20:35:12 GMT -5
Thread  
newBookmarkLockedFalling Right Side Case Cover Gasket
wideload 2 724 by madmax
Feb 13, 2012 9:08:01 GMT -5
Thread  
newBookmarkLockedFalling What are the correct clocks for a 79 "E" ?
madmax 5 1,053 by czechbiker
Jan 26, 2012 16:02:39 GMT -5
Thread  
newBookmarkLockedFalling Rev counter repair?
madmax 4 1,074 by madmax
Dec 23, 2011 6:11:00 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Trouble Shooting
All of your questions will be answered...hopefuly
Board Statistics
Threads and Posts
Total Threads:904
Total Posts:6,442
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5