Stupid Trick of the Week!

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Old (New) Triumph
Pages:
motormike 27 2,349 by ShakerNorm
Nov 1, 2010 18:46:51 GMT -5
Thread  
newBookmarkLockedFalling Wasted time
mikebritton 9 985 by xsleo
Oct 30, 2010 21:08:00 GMT -5
Thread  
newBookmarkLockedFalling JMC Swingarms
Pages:
fastfranky 16 4,255 by slide
Oct 18, 2010 16:55:28 GMT -5
Thread  
newBookmarkLockedFalling Are all chains created equal
Pages:
eeky 27 3,159 by exilemike
Sept 27, 2010 2:58:26 GMT -5
Thread  
newBookmarkLockedFalling Finally found something that vibrates more!
tww 2 957 by eagleeye
Sept 23, 2010 15:36:18 GMT -5
Thread  
newBookmarkLockedFalling How NOT to clean engine internals
plattey 7 1,151 by tomterrific
Jun 29, 2010 9:09:02 GMT -5
Thread  
newBookmarkLockedFalling I done a bad thing....
Mat 0 769 by Mat
Jun 17, 2010 8:06:24 GMT -5
Thread  
newBookmarkLockedFalling Og fix good!
grizld1 6 920 by ShakerNorm
May 27, 2010 19:00:53 GMT -5
Thread  
newBookmarkLockedFalling Close Encounters of the Beard Kind
leethal 3 952 by ShakerNorm
May 5, 2010 18:49:54 GMT -5
Thread  
newBookmarkLockedFalling Started out good, Ended Bad
grepper 11 1,094 by drooling-bloodhound
Apr 9, 2010 8:30:59 GMT -5
Thread  
newBookmarkLockedFalling Never assume....
grizld1 1 740 by ShakerNorm
Apr 5, 2010 18:07:21 GMT -5
Thread  
newBookmarkLockedFalling how to lose an eye
Pages:
justin 20 2,918 by 650beliver
Apr 2, 2010 22:37:40 GMT -5
Thread  
newBookmarkLockedFalling Protip:
tww 3 646 by tww
Feb 16, 2010 19:22:52 GMT -5
Thread  
newBookmarkLockedFalling Honda civic lower control arms $38 used
tww 6 4,408 by tww
Jan 19, 2010 23:04:50 GMT -5
Thread  
newBookmarkLockedFalling It's hard being dumb
Pages:
roar 24 2,278 by ShakerNorm
Oct 7, 2009 20:59:36 GMT -5
Thread  
newBookmarkLockedFalling sober
kopcicle 2 764 by roar
Oct 4, 2009 22:52:43 GMT -5
Thread  
newBookmarkLockedFalling Broke down blues
leethal 5 742 by tww
Sept 22, 2009 1:11:26 GMT -5
Thread  
newBookmarkLockedFalling Stupid NUTS!
ShakerNorm 0 770 by ShakerNorm
Aug 22, 2009 16:16:42 GMT -5
Thread  
newBookmarkLockedFalling Never assume....
grizld1 1 662 by ShakerNorm
Aug 12, 2009 23:50:42 GMT -5
Thread  
newBookmarkLockedFalling One cotter key, Opp's
10ecjed 1 650 by motormike
Jul 24, 2009 19:30:07 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Stupid Trick of the Week!
Come on, Fess up, we've all done something really goofy before!
Board Statistics
Threads and Posts
Total Threads:198
Total Posts:1,390
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5