Stupid Trick of the Week!

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Washers??
roar 5 876 by roar
Aug 15, 2008 9:17:05 GMT -5
Thread  
newBookmarkLockedFalling Flashed
looney 1 650 by XSv650
Aug 7, 2008 22:37:27 GMT -5
Thread  
newBookmarkLockedFalling Who checks oil?
cafefill 14 923 by leethal
Jul 26, 2008 7:11:11 GMT -5
Thread  
newBookmarkLockedFalling stupidest trick of the week
bill letson 1 728 by tomterrific
Jul 24, 2008 7:34:36 GMT -5
Thread  
newBookmarkLockedFalling Don't over tighten the head bolts.
choppercrazy 2 834 by shifty
Jul 15, 2008 15:28:23 GMT -5
Thread  
newBookmarkLockedFalling Looking Cool!
mtskull 7 896 by leethal
Jul 8, 2008 2:19:08 GMT -5
Thread  
newBookmarkLockedFalling This last weekend...
eric123 1 498 by moya034
Jul 4, 2008 7:47:09 GMT -5
Thread  
newBookmarkLockedFalling Keep on buying the wrong part
grepper 14 2,749 by grepper
Jun 24, 2008 15:14:20 GMT -5
Thread  
newBookmarkLockedFalling Don't Ignore the chain...
sevens0n 9 881 by xsleo
May 27, 2008 2:14:13 GMT -5
Thread  
newBookmarkLockedFalling 3/4's chance to grab the corret one
grepper 4 633 by xsleo
May 10, 2008 17:11:32 GMT -5
Thread  
newBookmarkLockedFalling Manual
tarchin 7 522 by grepper
May 9, 2008 10:53:08 GMT -5
Thread  
newBookmarkLockedFalling I have a Petcock
leethal 0 565 by leethal
Apr 30, 2008 1:22:52 GMT -5
Thread  
newBookmarkLockedFalling i hate myself and i want to die
justin 4 729 by justin
Apr 27, 2008 23:37:44 GMT -5
Thread  
newBookmarkLockedFalling Hi, my name is Brad...and I'm a Moron!
xs650sf 9 1,223 by papole
Apr 22, 2008 21:38:10 GMT -5
Thread  
newBookmarkLockedFalling My new oil level site hole
Fry 5 565 by Fry
Apr 20, 2008 16:37:37 GMT -5
Thread  
newBookmarkLockedFalling More stuff falling off
grepper 8 746 by CLAY
Feb 28, 2008 12:52:00 GMT -5
Thread  
newBookmarkLockedFalling Medical Emergency!
pamcopete 3 629 by pamcopete
Feb 26, 2008 11:13:53 GMT -5
Thread  
newBookmarkLockedFalling 5-speed 650cc table saw??? LMAO!!
XSv650 0 1,397 by XSv650
Feb 6, 2008 0:19:23 GMT -5
Thread  
newBookmarkLockedFalling Front sprocket black and blues
leethal 2 492 by motormike
Jan 28, 2008 13:36:26 GMT -5
Thread  
newBookmarkLockedFalling a new cut of BS38 slide Ive never seen before
jeremy 3 930 by jeremy
Jan 18, 2008 0:57:23 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Stupid Trick of the Week!
Come on, Fess up, we've all done something really goofy before!
Board Statistics
Threads and Posts
Total Threads:198
Total Posts:1,390
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5