The Electrical Basics

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Rectifier this!
speez 6 1,339 by xsleo
Apr 26, 2011 19:43:57 GMT -5
Thread  
newBookmarkLockedFalling rear brake switch
billychop 7 1,218 by ShakerNorm
Apr 15, 2011 18:49:00 GMT -5
Thread Locked  
newBookmarkLockedFalling Moved: Pamco Ignition for Racing
teamsd46 0 605 by teamsd46
Mar 31, 2011 14:33:23 GMT -5
Thread  
newBookmarkLockedFalling 72 xs2 pamco
nkymain485 1 960 by pamcopete
Feb 11, 2011 7:08:01 GMT -5
Thread  
newBookmarkLockedFalling Alternative Ignition System
petesxs 2 1,249 by ShakerNorm
Feb 8, 2011 21:54:13 GMT -5
Thread  
newBookmarkLockedFalling wiring diagram for '76 (Basic)
Pages:
undercoverbro 15 5,882 by ShakerNorm
Feb 8, 2011 0:53:33 GMT -5
Thread  
newBookmarkLockedFalling Chopper wiring w/pamco ign
Pages:
rwingsfan 17 6,225 by xsleo
Jan 9, 2011 16:38:02 GMT -5
Thread  
newBookmarkLockedFalling 78 engine in '81 frame
srbtjeep 2 674 by grepper
Jan 1, 2011 13:02:22 GMT -5
Thread  
newBookmarkLockedFalling brake light indicator wont turn off
skaere 0 497 by skaere
Oct 30, 2010 12:08:45 GMT -5
Thread  
newBookmarkLockedFalling blowing 7.5 amp fuses on pamco ign.
ohioninja 1 985 by pamcopete
Sept 23, 2010 5:48:36 GMT -5
Thread  
newBookmarkLockedFalling head light
justinjmo 3 998 by retiredgentleman
Aug 23, 2010 11:18:24 GMT -5
Thread  
newBookmarkLockedFalling Wiring 1972
andersroos 2 675 by andersroos
Aug 23, 2010 9:15:43 GMT -5
Thread  
newBookmarkLockedFalling Basic street system + batt, what to use?
scott87 5 1,023 by ShakerNorm
Aug 22, 2010 22:24:32 GMT -5
Thread  
newBookmarkLockedFalling 1976 XS650 Bobber Wiring w/ Pamco Ignition????
Pages:
sixthirtytwo 19 8,887 by sixthirtytwo
Aug 6, 2010 10:21:49 GMT -5
Thread  
newBookmarkLockedFalling Mistery part behind battery box
tz250racer 10 1,320 by dillrepair
Jul 20, 2010 23:32:23 GMT -5
Thread  
newBookmarkLockedFalling No spark and wires cut/missing
srinath 0 635 by srinath
Jun 28, 2010 14:58:32 GMT -5
Thread  
newBookmarkLockedFalling Checking condensors
dogbunny 8 1,280 by ShakerNorm
Jun 25, 2010 0:31:15 GMT -5
Thread  
newBookmarkLockedFalling small turn signals
tonyc2me 0 770 by tonyc2me
Jun 19, 2010 19:34:07 GMT -5
Thread  
newBookmarkLockedFalling Setting timing w/Pamco Pete setup
powershouse 4 4,433 by pamcopete
Jun 9, 2010 12:29:17 GMT -5
Thread  
newBookmarkLockedFalling Shortening plug wires
fleyeboy 3 932 by ShakerNorm
May 5, 2010 20:23:26 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
The Electrical Basics
Info and studies in electrical systems and componants, and how they pertain to the XS650.
Board Statistics
Threads and Posts
Total Threads:62
Total Posts:325
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5