Suggestions and thoughts on the board

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling scrolling?
82bobber 2 430 by 82bobber
Oct 5, 2006 7:00:44 GMT -5
Thread  
newBookmarkLockedFalling Exalt | Smite
shifty 4 468 by logan944t
Aug 13, 2006 16:39:03 GMT -5
Thread  
newBookmarkLockedFalling Email when there is a reply
dryeager 3 525 by Bob Dammit
May 11, 2006 22:54:17 GMT -5
Thread  
newBookmarkLockedFalling New Sub board titled "modifications" needed.
garyr 8 557 by Bob Dammit
Mar 30, 2006 21:23:59 GMT -5
Thread  
newBookmarkLockedFalling trouble with avatar
Excess Too 2 469 by Excess Too
Aug 27, 2005 18:27:59 GMT -5
Thread  
newBookmarkLockedFalling map it
boomer 0 390 by boomer
Jul 22, 2005 7:36:41 GMT -5
Thread  
newBookmarkLockedFalling trouble with sig
lilbill 2 377 by Bob Dammit
Jun 5, 2005 19:31:27 GMT -5
Thread  
newBookmarkLockedFalling trip forum....
appalacious 2 433 by Bob Dammit
May 17, 2005 22:22:38 GMT -5
Thread  
newBookmarkLockedFalling tracking by poster
Burns 4 426 by Bob Dammit
May 11, 2005 21:09:05 GMT -5
Thread  
newBookmarkLockedFalling reversed fonts
Burns 3 333 by Diesel
May 9, 2005 17:51:19 GMT -5
Thread  
newBookmarkLockedFalling trouble with my profile
trebchopper 3 441 by trebchopper
May 9, 2005 3:20:12 GMT -5
Thread  
newBookmarkLockedFalling "SENT"
Burns 3 415 by Bob Dammit
Apr 24, 2005 21:34:16 GMT -5
Thread  
newBookmarkLockedFalling I'm just glad to be here!
markshoreline 3 372 by EvergreenXS
Apr 4, 2005 14:44:01 GMT -5
Thread  
newBookmarkLockedFalling Modest suggestions
Burns 1 354 by Bob Dammit
Mar 23, 2005 22:09:27 GMT -5
Thread Locked  
newBookmarkLockedFalling Moved: On Board
knuckles 0 379 by knuckles
Mar 18, 2005 22:57:19 GMT -5
Thread  
newBookmarkLockedFalling Top image
Kurt 5 479 by Polamnus
Mar 17, 2005 22:38:11 GMT -5
Thread  
newBookmarkLockedFalling Ride reports
Gham 0 348 by Gham
Feb 20, 2005 19:22:52 GMT -5
Thread  
newBookmarkLockedFalling Looking for a ASP.NET server
Bob Dammit 0 376 by Bob Dammit
Feb 13, 2005 11:57:23 GMT -5
Thread  
newBookmarkLockedFalling Hello
crazypj22 1 369 by Bob Dammit
Feb 10, 2005 22:02:21 GMT -5
Thread  
newBookmarkLockedFalling Thanks for the welcome. . . .
Cruiser 3 424 by Burns
Feb 8, 2005 17:29:47 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Suggestions and thoughts on the board
Let me know what you think
Board Statistics
Threads and Posts
Total Threads:90
Total Posts:486
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5