Introductions

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Hello, new here
purplez 3 685 by preston
Sept 3, 2013 7:59:52 GMT -5
Thread  
newBookmarkLockedFalling Saying hello I'm new
shawn77 1 2,159 by 10ecjed
Jul 22, 2013 12:19:57 GMT -5
Thread  
newBookmarkLockedFalling can't get enough xs!
deadchef 6 779 by jetmechmarty
Jun 24, 2013 21:17:04 GMT -5
Thread  
newBookmarkLockedFalling PO '78 650 Special
shacky 7 1,066 by ShakerNorm
Jun 9, 2013 11:25:40 GMT -5
Thread  
newBookmarkLockedFalling I am Jerry and I am building a chopper
mastertech44 2 673 by ShakerNorm
Jun 3, 2013 23:45:50 GMT -5
Thread  
newBookmarkLockedFalling NOOB
brucedeuce 5 996 by ShakerNorm
Jun 3, 2013 23:39:19 GMT -5
Thread  
newBookmarkLockedFalling A new old guy aboard....!
lsrh66 3 799 by 10ecjed
Jan 7, 2013 18:30:59 GMT -5
Thread  
newBookmarkLockedFalling Hi from Wiltshire UK
pixie 7 1,388 by xs1961
Dec 29, 2012 9:34:48 GMT -5
Thread  
newBookmarkLockedFalling Returning member, might as well be new2
snakeoil 0 728 by snakeoil
Oct 15, 2012 17:07:47 GMT -5
Thread  
newBookmarkLockedFalling HELP ! mechanic ref. in W. NY; W. PA ; or N.E. OH.
boogywstew 11 985 by ShakerNorm
Apr 28, 2012 21:07:31 GMT -5
Thread Locked  
newBookmarkLockedFalling Moved: Used Parts
offxs650 0 497 by offxs650
Apr 21, 2012 13:09:24 GMT -5
Thread  
newBookmarkLockedFalling HELP ! Need mechanic reference in Erie, PA
boogywstew 1 676 by ShakerNorm
Apr 20, 2012 23:41:26 GMT -5
Thread  
newBookmarkLockedFalling new to the site hello to everyone
demon3 1 520 by tonyc2me
Apr 6, 2012 13:37:55 GMT -5
Thread  
newBookmarkLockedFalling hey to all
klytis 1 565 by grizld1
Mar 28, 2012 20:06:53 GMT -5
Thread  
newBookmarkLockedFalling Hello from Yorkshire, UK
tombo 1 519 by wilkie
Jan 17, 2012 17:05:21 GMT -5
Thread  
newBookmarkLockedFalling I Smell Castrol!
BubbaLeone 1 580 by grizld1
Jan 16, 2012 10:15:36 GMT -5
Thread  
newBookmarkLockedFalling Bigshmeil from Long Island, NY
bigshmeil 1 583 by madmax
Jan 2, 2012 8:54:10 GMT -5
Thread  
newBookmarkLockedFalling tommerr newbe (as in Viet Nam newbe)
tommerr 1 485 by grizld1
Dec 19, 2011 8:16:33 GMT -5
Thread  
newBookmarkLockedFalling new to the garage.
sickofitall 2 686 by rawolf
Nov 24, 2011 8:55:26 GMT -5
Thread  
newBookmarkLockedFalling Alpha Dog from Philadelphia
alphadog 1 1,057 by ShakerNorm
Oct 15, 2011 16:48:56 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Introductions
Introduce yourself to the members of the XS650 Garage!
Board Statistics
Threads and Posts
Total Threads:382
Total Posts:1,141
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5