Introductions

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling whoooo
doublecobras 7 490 by kopcicle
May 13, 2011 1:32:41 GMT -5
Thread  
newBookmarkLockedFalling Hey Ty
kansashillbilly 4 595 by ShakerNorm
May 5, 2011 20:08:06 GMT -5
Thread  
newBookmarkLockedFalling NEW MEMEBER!!!
mastertacks 2 503 by azman857
May 1, 2011 14:39:13 GMT -5
Thread  
newBookmarkLockedFalling New member
jeffnfranklintn 2 490 by ShakerNorm
Apr 27, 2011 0:19:52 GMT -5
Thread  
newBookmarkLockedFalling New to my bike as well as message boards
retrorider 3 505 by weaselbeak
Apr 21, 2011 18:32:28 GMT -5
Thread  
newBookmarkLockedFalling Howdy
octaval 3 545 by ShakerNorm
Apr 16, 2011 21:00:10 GMT -5
Thread  
newBookmarkLockedFalling Member from Guatemala!!
Pages:
richsuz 18 1,596 by richsuz
Apr 16, 2011 15:38:25 GMT -5
Thread  
newBookmarkLockedFalling New, but not really
weaselbeak 4 550 by ShakerNorm
Apr 16, 2011 10:50:53 GMT -5
Thread  
newBookmarkLockedFalling Newb from Venezuela
bobberxs650 1 439 by ShakerNorm
Apr 9, 2011 11:30:17 GMT -5
Thread  
newBookmarkLockedFalling Another Newb
luckyb 2 605 by azman857
Apr 3, 2011 12:25:22 GMT -5
Thread  
newBookmarkLockedFalling just got my first bike
timmyinva 1 582 by ShakerNorm
Apr 2, 2011 12:02:17 GMT -5
Thread  
newBookmarkLockedFalling Newb in Saint Louis
bradical 2 608 by bradical
Mar 17, 2011 21:16:37 GMT -5
Thread  
newBookmarkLockedFalling nube
chazzer 2 555 by markabird
Mar 17, 2011 8:41:20 GMT -5
Thread  
newBookmarkLockedFalling New to the bored
bigjohns3 1 397 by grizld1
Feb 16, 2011 21:50:02 GMT -5
Thread  
newBookmarkLockedFalling Chuckwagon 1.0 is here.
Chuckwagon 2 631 by Chuckwagon
Jan 23, 2011 19:12:13 GMT -5
Thread  
newBookmarkLockedFalling Hi from NorCal
primus 1 439 by ShakerNorm
Jan 19, 2011 21:25:51 GMT -5
Thread  
newBookmarkLockedFalling New to the Forum
windsculptor 1 479 by robbo
Jan 18, 2011 7:54:14 GMT -5
Thread  
newBookmarkLockedFalling G,day All..
robbo 1 480 by ShakerNorm
Jan 15, 2011 11:18:51 GMT -5
Thread  
newBookmarkLockedFalling Hello From San Diego
619xs650 3 654 by xsleo
Jan 9, 2011 19:07:03 GMT -5
Thread  
newBookmarkLockedFalling Hello all
fat xs650 4 566 by fat xs650
Dec 29, 2010 21:21:15 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Introductions
Introduce yourself to the members of the XS650 Garage!
Board Statistics
Threads and Posts
Total Threads:382
Total Posts:1,141
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5