Lighting

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Single wire LED run,brake,turn
judgeroy 6 2,798 by mrriggs
Aug 7, 2011 23:58:18 GMT -5
Thread  
newBookmarkLockedFalling blowing signal fuse
rogercarrier 2 1,028 by rogercarrier
Jul 18, 2011 15:01:50 GMT -5
Thread  
newBookmarkLockedFalling No headlight/ No start
dougthepostie 1 684 by ShakerNorm
Jul 10, 2011 15:38:28 GMT -5
Thread  
newBookmarkLockedFalling turn signal ?
necos650 9 1,815 by dillrepair
Jul 7, 2011 19:20:07 GMT -5
Thread  
newBookmarkLockedFalling eliminating "distance sensor" and other lights
Pages:
Chuckwagon 30 3,939 by Chuckwagon
Jul 1, 2011 9:04:32 GMT -5
Thread  
newBookmarkLockedFalling "Headlight" Light coming on at high RPMS
highsidednb 3 892 by xulf13
Jun 30, 2011 19:23:54 GMT -5
Thread  
newBookmarkLockedFalling Yellow Headlight Lens
JohnnyGold 3 1,202 by ShakerNorm
Jun 25, 2011 13:30:59 GMT -5
Thread  
newBookmarkLockedFalling turn signal fix for u guys with problems
dpmulvan 6 3,080 by wideload
Jun 11, 2011 12:42:56 GMT -5
Thread  
newBookmarkLockedFalling Blinks only with motor not running
lassieau 9 856 by ShakerNorm
Jun 9, 2011 17:55:09 GMT -5
Thread  
newBookmarkLockedFalling To those with flasher problems
dpmulvan 1 461 by xsleo
Jun 9, 2011 12:03:54 GMT -5
Thread  
newBookmarkLockedFalling Turn signal isssue.
imcgyver 6 734 by ShakerNorm
Jun 5, 2011 22:23:53 GMT -5
Thread  
newBookmarkLockedFalling Mopey looking rear brake light
Chuckwagon 3 537 by xsleo
May 29, 2011 17:51:49 GMT -5
Thread  
newBookmarkLockedFalling Banjo brake light switch... Junk.
Chuckwagon 4 925 by Chuckwagon
May 24, 2011 10:37:50 GMT -5
Thread  
newBookmarkLockedFalling Mikes XS Speedo to Stock Wiring Harness
tchcmike 2 1,030 by tchcmike
May 22, 2011 17:39:39 GMT -5
Thread  
newBookmarkLockedFalling Weight of complete 1977 Standard Headlight
arcticxs 0 453 by arcticxs
May 13, 2011 12:11:47 GMT -5
Thread  
newBookmarkLockedFalling 5 3/4 headlight mounting bracket
snowman789 1 643 by slow86gn
Apr 16, 2011 13:53:18 GMT -5
Thread  
newBookmarkLockedFalling HID Proper Installation?
ronnieryan 2 2,998 by ShakerNorm
Apr 9, 2011 12:00:53 GMT -5
Thread  
newBookmarkLockedFalling Let there be light
kopcicle 0 678 by kopcicle
Apr 9, 2011 4:16:40 GMT -5
Thread  
newBookmarkLockedFalling No rear signals
JohnnyGold 3 499 by xsleo
Apr 2, 2011 13:10:40 GMT -5
Thread  
newBookmarkLockedFalling Turn Signal Flasher Location
pamcopete 4 1,369 by xsleo
Jan 9, 2011 16:13:09 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Lighting
Including headlights, taillights, brake lights, turn signals, upgrades, LED's and lighting reserve boxes.
Board Statistics
Threads and Posts
Total Threads:313
Total Posts:1,760
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5