Lighting

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling headlight wiring
dzais 7 3,315 by Aux
Jun 9, 2010 22:07:00 GMT -5
Thread  
newBookmarkLockedFalling Another Blinker Problem
davecycleman 1 836 by xsleo
Jun 1, 2010 18:52:52 GMT -5
Thread  
newBookmarkLockedFalling turn signals on street tracker
snydermr2 1 602 by ShakerNorm
May 19, 2010 21:18:44 GMT -5
Thread  
newBookmarkLockedFalling LED bulb product question
nevada650 11 889 by ShakerNorm
May 16, 2010 17:06:29 GMT -5
Thread  
newBookmarkLockedFalling turn signal question
nevada650 3 727 by nevada650
May 11, 2010 19:22:01 GMT -5
Thread  
newBookmarkLockedFalling DOT approved Lucas Tail ligh?
kaslon 4 920 by lordeoin
May 11, 2010 11:22:33 GMT -5
Thread  
newBookmarkLockedFalling Tail Light from hell
rdgerber2 3 664 by rdgerber2
Apr 26, 2010 12:34:11 GMT -5
Thread  
newBookmarkLockedFalling headlight replacement
skinnycowboy 3 611 by ShakerNorm
Apr 24, 2010 17:42:19 GMT -5
Thread  
newBookmarkLockedFalling led signal flasher
grinder 8 3,025 by ShakerNorm
Apr 9, 2010 23:47:18 GMT -5
Thread  
newBookmarkLockedFalling Headlight of Horror
tiredguy 5 903 by ShakerNorm
Mar 30, 2010 18:06:00 GMT -5
Thread  
newBookmarkLockedFalling Best headlight anybody?
cheftay 3 794 by uwbernie
Mar 30, 2010 9:04:34 GMT -5
Thread  
newBookmarkLockedFalling Turn Signal grounding problem
ShakerNorm 4 1,166 by ShakerNorm
Mar 21, 2010 17:42:44 GMT -5
Thread  
newBookmarkLockedFalling relay to turn off headlight when in neutral
LesS 1 2,026 by pamcopete
Mar 8, 2010 16:23:18 GMT -5
Thread  
newBookmarkLockedFalling removing stock frt turn signals
stevewagner 7 780 by pamcopete
Feb 26, 2010 12:36:10 GMT -5
Thread  
newBookmarkLockedFalling After Market Headlight Brackets Crack
aarmstro83 2 1,167 by grepper
Feb 26, 2010 8:16:37 GMT -5
Thread  
newBookmarkLockedFalling Motorcycle Garage Door Opener
hill95 9 836 by pamcopete
Feb 12, 2010 18:22:46 GMT -5
Thread  
newBookmarkLockedFalling replacing stock tail light for a 1980 special
kaslon 2 576 by kaslon
Feb 8, 2010 10:58:03 GMT -5
Thread  
newBookmarkLockedFalling 1157 LED
grinder 4 772 by xsleo
Feb 8, 2010 1:59:02 GMT -5
Thread  
newBookmarkLockedFalling Confused by Victory
leethal 3 669 by retiredgentleman
Dec 25, 2009 13:05:39 GMT -5
Thread  
newBookmarkLockedFalling Signal and Brake questions
curt698 2 587 by spyug
Dec 21, 2009 11:24:37 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Lighting
Including headlights, taillights, brake lights, turn signals, upgrades, LED's and lighting reserve boxes.
Board Statistics
Threads and Posts
Total Threads:313
Total Posts:1,760
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5