Exhaust

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Mikesxs Commando exhaust jetting needed???
garyr 12 3,524 by garyr
Jul 24, 2011 12:50:58 GMT -5
Thread  
newBookmarkLockedFalling Muffler reducers
tbucketer 1 1,032 by tomterrific
Jun 19, 2011 8:31:17 GMT -5
Thread  
newBookmarkLockedFalling home made glass pack
xs650shawn 2 1,164 by ShakerNorm
Jun 7, 2011 18:29:00 GMT -5
Thread  
newBookmarkLockedFalling 1 3/4 SS to Emgo Dunstall Wide O Replica Muffler
fermatseye 2 1,303 by fermatseye
Jun 4, 2011 13:55:29 GMT -5
Thread  
newBookmarkLockedFalling commando exhaust system help needed
Pages:
Chuckwagon 25 3,575 by xsleo
May 29, 2011 19:36:55 GMT -5
Thread  
newBookmarkLockedFalling new exhaust supplier coming
pablosixfivezero 11 3,176 by arcticxs
May 22, 2011 20:03:10 GMT -5
Thread  
newBookmarkLockedFalling Header pipe
kansashillbilly 4 830 by kansashillbilly
May 10, 2011 23:51:14 GMT -5
Thread  
newBookmarkLockedFalling Modification of real Norton Commando peashooters
arcticxs 0 1,812 by arcticxs
Apr 23, 2011 4:09:29 GMT -5
Thread  
newBookmarkLockedFalling Bolt for exhaust to frame.
gdcpony 1 628 by madmax
Apr 22, 2011 8:01:09 GMT -5
Thread  
newBookmarkLockedFalling Mikes XS new 2-1 exhaust
Pages:
Fry 47 10,210 by prairiedog
Apr 20, 2011 17:09:32 GMT -5
Thread  
newBookmarkLockedFalling Turn out mufflers- Any feedback?
tbucketer 7 951 by Chuckwagon
Apr 20, 2011 13:45:36 GMT -5
Thread  
newBookmarkLockedFalling BLOWING SMOKE...
rattattat 10 2,702 by rattattat
Apr 16, 2011 20:00:46 GMT -5
Thread  
newBookmarkLockedFalling Header pipes
snowman789 1 743 by ShakerNorm
Apr 16, 2011 10:58:41 GMT -5
Thread  
newBookmarkLockedFalling 1 1/2"OD or 1 3/4"OD on stock motor ??
Pages:
mhanks71 22 3,606 by slide
Apr 6, 2011 11:53:04 GMT -5
Thread  
newBookmarkLockedFalling Good looks and good sound, possible to have both?
arcticxs 5 1,110 by 5twins
Apr 3, 2011 12:00:54 GMT -5
Thread  
newBookmarkLockedFalling Shorty mufflers
tchcmike 2 1,166 by tchcmike
Mar 23, 2011 20:00:27 GMT -5
Thread  
newBookmarkLockedFalling Pea Shooters on 1.5" headers
rambler 11 1,740 by rambler
Mar 9, 2011 20:48:48 GMT -5
Thread  
newBookmarkLockedFalling Exhaust Stud Just Ripped Out
cootersandwich 1 939 by xsleo
Feb 25, 2011 17:28:09 GMT -5
Thread  
newBookmarkLockedFalling SUPER Short Pipes by Ardcore
cootersandwich 8 1,405 by cootersandwich
Feb 22, 2011 1:05:06 GMT -5
Thread  
newBookmarkLockedFalling Exhaust sound.
wdb45 5 1,143 by 5twins
Feb 8, 2011 19:43:22 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Exhaust
Exhaust
Board Statistics
Threads and Posts
Total Threads:270
Total Posts:1,782
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5