Parts Wanted

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Headpipe Torque Inserts (Exhaust CONES)
mastertacks 0 740 by mastertacks
Apr 28, 2011 14:08:12 GMT -5
Thread  
newBookmarkLockedFalling Wheels
kopcicle 0 350 by kopcicle
Apr 26, 2011 15:30:07 GMT -5
Thread  
newBookmarkLockedFalling Single tube case breather
billychop 2 691 by hammerin
Apr 26, 2011 12:34:28 GMT -5
Thread  
newBookmarkLockedFalling Header pipes
Mat 3 910 by sarah1
Apr 17, 2011 7:03:28 GMT -5
Thread  
newBookmarkLockedFalling Tappet Adjustor Screws
islanddave 2 479 by xsleo
Apr 16, 2011 19:04:40 GMT -5
Thread  
newBookmarkLockedFalling nylon Alt screws
kiwi 4 818 by xsleo
Mar 7, 2011 21:38:05 GMT -5
Thread  
newBookmarkLockedFalling Adjustable backrest/ sissy bar
squid 2 899 by antisaint
Mar 7, 2011 16:52:59 GMT -5
Thread  
newBookmarkLockedFalling Timing chain sprockets
twinfan 2 664 by xsleo
Feb 25, 2011 19:18:09 GMT -5
Thread  
newBookmarkLockedFalling Tach Drive Complete
islanddave 0 359 by islanddave
Feb 12, 2011 12:42:41 GMT -5
Thread  
newBookmarkLockedFalling Complete Engine wanted (in aus)
robbo 2 1,068 by Göran Persson
Feb 12, 2011 3:45:38 GMT -5
Thread  
newBookmarkLockedFalling Rear disc brake parts
Ironriot 1 328 by tonyc2me
Jan 31, 2011 1:09:21 GMT -5
Thread  
newBookmarkLockedFalling Standard Gas Cap
grepper 1 538 by grepper
Jan 26, 2011 16:16:29 GMT -5
Thread  
newBookmarkLockedFalling Wanted - 1972 Front Forks 34mm
thekinghimself 1 540 by thekinghimself
Jan 6, 2011 22:42:26 GMT -5
Thread  
newBookmarkLockedFalling Wtb: right side carb housing 1980 xs
mikemigs 0 395 by mikemigs
Jan 3, 2011 15:29:18 GMT -5
Thread  
newBookmarkLockedFalling coils
jdn40 2 716 by jdn40
Nov 29, 2010 20:17:45 GMT -5
Thread  
newBookmarkLockedFalling choke lever
flthead 0 348 by flthead
Nov 26, 2010 18:34:29 GMT -5
Thread  
newBookmarkLockedFalling Xs1 parts
motormike 0 401 by motormike
Nov 26, 2010 15:30:46 GMT -5
Thread  
newBookmarkLockedFalling XS1 PARTS WANTED
theozslider 7 699 by theozslider
Nov 25, 2010 9:16:52 GMT -5
Thread  
newBookmarkLockedFalling left side handlebar switches
jdn40 7 1,061 by theozslider
Nov 25, 2010 9:12:51 GMT -5
Thread  
newBookmarkLockedFalling WTB: '74-76 front hub, left side cover
b. 0 330 by b.
Nov 10, 2010 10:22:16 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Parts Wanted
Need a particular XS650 part? List your needs here!
Board Statistics
Threads and Posts
Total Threads:924
Total Posts:2,783
This board has 2 moderators
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5