General Electrical Issues

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Can't contact pamco pete
retread 3 2,478 by Slimbob
Sept 18, 2012 14:47:12 GMT -5
Thread  
newBookmarkLockedFalling Help with Dry then drained battery
Slimbob 11 1,230 by xsleo
Sept 11, 2012 9:22:52 GMT -5
Thread  
newBookmarkLockedFalling CDI unit fault symptoms
xs1961 3 1,012 by xs1961
Sept 10, 2012 2:53:33 GMT -5
Thread  
newBookmarkLockedFalling intermittent spark
scout4924 1 714 by preston
Sept 9, 2012 20:37:16 GMT -5
Thread  
newBookmarkLockedFalling will an '82 work with 2 coils?
metalfingers 12 1,217 by metalfingers
Aug 4, 2012 12:11:16 GMT -5
Thread  
newBookmarkLockedFalling At wits end again
10ecjed 11 937 by 10ecjed
Jul 18, 2012 20:24:36 GMT -5
Thread  
newBookmarkLockedFalling Need help mounting new coil for Pamco Ignition
Slimbob 8 2,103 by Slimbob
Jul 16, 2012 11:49:38 GMT -5
Thread  
newBookmarkLockedFalling rec-reg. don't know what one I have
chas 3 919 by xsleo
Jul 12, 2012 10:24:01 GMT -5
Thread  
newBookmarkLockedFalling diminishing spark.
kzcafeace 0 505 by kzcafeace
Jul 10, 2012 17:03:25 GMT -5
Thread  
newBookmarkLockedFalling BAD Coil????
xulf13 2 806 by xulf13
Jul 9, 2012 15:32:41 GMT -5
Thread  
newBookmarkLockedFalling Help with Ignition Mechanical Advance R&R
Slimbob 2 1,004 by Slimbob
Jul 3, 2012 17:28:10 GMT -5
Thread  
newBookmarkLockedFalling 75xs/ no power
ts37p08 2 679 by ShakerNorm
Jun 22, 2012 23:05:16 GMT -5
Thread  
newBookmarkLockedFalling Mike's/650central-missing starter repair kits ?
boogywstew 6 1,566 by ShakerNorm
Apr 28, 2012 21:20:25 GMT -5
Thread  
newBookmarkLockedFalling "magic" starter
Burns 1 593 by xsleo
Apr 14, 2012 19:24:27 GMT -5
Thread  
newBookmarkLockedFalling DIY wire harnes/fuse?
rz5mark 5 1,000 by xsleo
Apr 14, 2012 19:20:33 GMT -5
Thread  
newBookmarkLockedFalling do my powder coated bars need grounded?
scout4924 9 741 by xsleo
Apr 14, 2012 19:12:43 GMT -5
Thread  
newBookmarkLockedFalling start button - kill switch relationship
scout4924 2 942 by scout4924
Apr 2, 2012 23:14:41 GMT -5
Thread  
newBookmarkLockedFalling OEM style electric connections
timg 1 625 by xsleo
Nov 24, 2011 15:17:30 GMT -5
Thread  
newBookmarkLockedFalling Fuse to coil & PAMCO keeps blowing
Pages:
powershouse 24 2,920 by xsleo
Oct 29, 2011 19:40:46 GMT -5
Thread  
newBookmarkLockedFalling yamaha xs2
chazzer 0 624 by chazzer
Oct 8, 2011 1:42:06 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
General Electrical Issues
Starters, relays, fuse boxes, wiring diagrams, etc. Not sure where to post your electrical or wiring problems? This is the place.
Board Statistics
Threads and Posts
Total Threads:1,015
Total Posts:5,058
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5