Chassis Talk

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling key#3285 wanted
tonyc2me 1 693 by preston
Jul 6, 2013 15:48:49 GMT -5
Thread  
newBookmarkLockedFalling key#3285 wanted
tonyc2me 0 451 by tonyc2me
Jul 6, 2013 14:52:36 GMT -5
Thread  
newBookmarkLockedFalling rear frme section wanted
cbrrudy 1 732 by grizld1
Jun 19, 2013 8:29:23 GMT -5
Thread  
newBookmarkLockedFalling swingarm bushing dimensions
63a 8 2,179 by troopthrowback
Jun 11, 2013 16:51:54 GMT -5
Thread  
newBookmarkLockedFalling Brat vs hardtail handling
trebor13 5 1,789 by skidro
May 8, 2013 12:56:47 GMT -5
Thread  
newBookmarkLockedFalling problem with great suspension
Pages:
10ecjed 15 2,028 by preston
May 5, 2013 20:42:37 GMT -5
Thread  
newBookmarkLockedFalling Forward shock mounts
Burns 7 958 by garbln
Mar 24, 2013 10:09:58 GMT -5
Thread  
newBookmarkLockedFalling Help Please - IDing these forks
beekay 8 887 by Burns
Feb 9, 2013 16:02:58 GMT -5
Thread  
newBookmarkLockedFalling Mike's XS Monza shocks?
Pages:
Chuckwagon 57 11,749 by 10ecjed
Feb 5, 2013 17:32:24 GMT -5
Thread  
newBookmarkLockedFalling 340mm vs 350mm rear shocks
spacmanspif300 2 926 by spacmanspif300
Jan 24, 2013 11:21:43 GMT -5
Thread  
newBookmarkLockedFalling need a tool
rebelron 13 1,351 by 5twins
Dec 5, 2012 18:37:38 GMT -5
Thread  
newBookmarkLockedFalling Emblems
brucedeuce 7 988 by bowietwin
Dec 2, 2012 2:02:12 GMT -5
Thread  
newBookmarkLockedFalling Lower Fork Tube Bushings
taddpole76 2 754 by taddpole76
Nov 24, 2012 10:36:40 GMT -5
Thread  
newBookmarkLockedFalling Swingarms
snakeoil 8 1,171 by snakeoil
Oct 20, 2012 13:12:22 GMT -5
Thread  
newBookmarkLockedFalling Fork Clamp Width
terribletabo1 8 1,090 by slide
Oct 16, 2012 10:29:49 GMT -5
Thread  
newBookmarkLockedFalling aluminum 1 piece motocross style handlebar
terribletabo1 0 625 by terribletabo1
Sept 15, 2012 7:54:30 GMT -5
Thread  
newBookmarkLockedFalling Steering damper
10ecjed 1 1,088 by grizld1
Aug 15, 2012 20:23:01 GMT -5
Thread  
newBookmarkLockedFalling '81 Fork Sticking During Assembly
lcanavan317 2 803 by lcanavan317
Aug 10, 2012 21:43:52 GMT -5
Thread  
newBookmarkLockedFalling 15deg forward engine tilt
beekay 2 925 by beekay
Jul 9, 2012 15:33:25 GMT -5
Thread  
newBookmarkLockedFalling Brass swing arm bushings?
oldiron 4 1,027 by beekay
Jul 9, 2012 13:17:21 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Chassis Talk
Frames, Forks, Swingarms, Etc
Board Statistics
Threads and Posts
Total Threads:1,312
Total Posts:8,171
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5