Chassis Talk

Status    Subject Created By Replies Views Last Post
Thread  
newBookmarkLockedFalling Are 77-D Rear Shocks rebuildable?
Slimbob 6 971 by ShakerNorm
Jun 22, 2012 23:08:40 GMT -5
Thread  
newBookmarkLockedFalling one handed wobble!
scout4924 5 815 by xsleo
Jun 5, 2012 20:22:33 GMT -5
Thread  
newBookmarkLockedFalling Dual-Rate Fork Spring Kit
terribletabo1 5 1,758 by xsleo
May 8, 2012 17:01:03 GMT -5
Thread  
newBookmarkLockedFalling WORN OUT FOOTPEG THREADS
theozslider 6 1,127 by ricko77
Apr 30, 2012 11:49:54 GMT -5
Thread  
newBookmarkLockedFalling Where to buy Standard Seat with No Logo
terribletabo1 3 873 by terribletabo1
Apr 24, 2012 16:42:17 GMT -5
Thread  
newBookmarkLockedFalling 80 fork problem
Pages:
rebelron 17 2,261 by preston
Apr 4, 2012 20:53:49 GMT -5
Thread  
newBookmarkLockedFalling tubes and springs
Pages:
Burns 17 2,572 by scout4924
Mar 9, 2012 1:43:20 GMT -5
Thread  
newBookmarkLockedFalling Ikon 7610-1348 Shocks
glaswerks 4 2,412 by 5twins
Mar 6, 2012 12:11:30 GMT -5
Thread  
newBookmarkLockedFalling What years work ...seat compatibility
excess650 7 1,505 by xsleo
Feb 23, 2012 20:48:22 GMT -5
Thread  
newBookmarkLockedFalling Swing arm bearings
first650 5 1,500 by rebelron
Feb 22, 2012 22:02:00 GMT -5
Thread  
newBookmarkLockedFalling Tubular Travials
Burns 5 855 by Burns
Feb 18, 2012 17:18:52 GMT -5
Thread  
newBookmarkLockedFalling bushing removal
rebelron 2 694 by preston
Feb 17, 2012 7:49:43 GMT -5
Thread  
newBookmarkLockedFalling 72 xs650 springer
lerry72404 4 1,588 by xsleo
Jan 29, 2012 18:26:11 GMT -5
Thread  
newBookmarkLockedFalling Sub Frame Oil Cooler
terribletabo1 1 1,839 by xsleo
Jan 29, 2012 18:16:20 GMT -5
Thread  
newBookmarkLockedFalling Indian/XS650 Hybrid Frame?
terribletabo1 2 1,269 by terribletabo1
Jan 19, 2012 9:52:03 GMT -5
Thread  
newBookmarkLockedFalling Is anyone familiar with these Cheney Racing Frames
terribletabo1 6 6,763 by BubbaLeone
Jan 16, 2012 12:00:16 GMT -5
Thread  
newBookmarkLockedFalling intergrated brakes
flea 9 1,039 by crazypj22
Jan 15, 2012 17:03:53 GMT -5
Thread  
newBookmarkLockedFalling Tire sizes for Radian swingarm
greasyc 3 1,641 by greasyc
Jan 15, 2012 14:02:11 GMT -5
Thread  
newBookmarkLockedFalling Fork seal replacement
markee 1 556 by preston
Jan 10, 2012 22:32:06 GMT -5
Thread  
newBookmarkLockedFalling fork brace
flea 2 1,288 by flea
Dec 10, 2011 18:25:19 GMT -5

Legend

Thread Announcement Sticky Locked new New Poll Bookmark

Board Information & Statistics

Board Description
Chassis Talk
Frames, Forks, Swingarms, Etc
Board Statistics
Threads and Posts
Total Threads:1,312
Total Posts:8,171
This board has 1 moderator
Members
On This Board
You cannot create threads.
You cannot reply to threads.
You cannot create polls.
Members Online
Users Viewing
0 Staff, 0 Members, 1 Guest.

Shoutbox

r80rt: :)This is a splendid write up, THANK YOU!!!! Dec 26, 2015 16:54:05 GMT -5
mashermoto: What the what is this shoutbox for? Or should I shout, WHAT THE WHAT IS THIS SHOUTBOX FOR! May 12, 2016 22:22:21 GMT -5
motormike: Good Day ...just a FYI.. Wild Cat is this Labor Day weekend. Still go'n on. A few 650's still make the scene. Various rides at different skill levels each day.. awards dinner sunday eve. BS in the park'n lot after dinner. :) Aug 23, 2016 7:57:01 GMT -5
lsettle: First post in over 6 years! Aug 28, 2016 19:45:17 GMT -5
kardon: Wow quiet here, where did they all go. Oct 7, 2016 2:18:13 GMT -5
gggGary: XS650.com LOL Feb 16, 2017 20:49:02 GMT -5
buell88: Anybody have any idea who built the xs650 tracker used in the Draggin Jeans Ad on Pipeburn? May 16, 2017 16:24:09 GMT -5
joshua: The regulator/rectifier unit I got from Mikes PMA has closer hole spacing than original. Are we supposed to mill the holes to fit? Jun 7, 2017 19:25:58 GMT -5
joshua: My bad. I found the bracket they supplied to mount the rectifier/regulator... Uh oh. How is this meant to work? Which way is it meant to mount? Looks like I have to use some spacers or something. Good instructions would be nice. Jun 7, 2017 22:09:52 GMT -5
craig8johnson: Not sure if this is the right spot or not but oh well... Jul 11, 2017 18:04:15 GMT -5
craig8johnson: I'm checking the charging system. I'm afraid I might have fried the last battery. With the solid state regulator (after market) what should it be charging at. The book says, I think, 15 volts. I'm hitting 17 when revved. Is that too high? Jul 11, 2017 18:06:19 GMT -5
gggGary: Yes 17 volts is too high, about 14 volts is max, sounds like you don't have the right regulator or it's wired wrong. Jul 13, 2017 6:54:33 GMT -5
dean: Just saying Hello, new member who is going to fix up a 79 XS650 that has seen its better days. I will definitely have lots of questions coming up. Jun 23, 2018 16:45:32 GMT -5
tt650: Trying to breathe life into a 1980 that's been stored (indoors) for 25 yrs. Air filters are dry rotted. Have cleaned carbs but she only runs briefly on choke then stops. Need jet setting info and other ideas that might help her idle and rev. Jul 3, 2018 19:15:19 GMT -5
trix13: Hey everyone! New to the forum and am fighting those gremlins!! New charging system, ignition switch, coil and fuse box. Resistance is higher than normal on the ignition pick up so I'm trying to find one. No such luck yet. Aug 16, 2018 8:50:48 GMT -5
trix13: Also, even though all of my connections are clean, I cannot seem to find out why , when at higher rpms, I hit the signals and the rpms pulse with the signals...hahah. same with the brake light. I appreciate all input!! Aug 16, 2018 8:55:08 GMT -5
bob99: how do I post a question. I am new to the forum Jun 6, 2019 10:52:10 GMT -5
adlpc: Hello all! Been enjoying your edifying posts and discussions - and as a fan of the XS650 since my early teenage years happy that I now own a 1980 Special which I plan to turn into a vintage half faired racer. Thank you all for being here! Oct 1, 2019 0:58:56 GMT -5
jimothyj: Hello everyone, I just joined & wish would have known about this site in 2014 when I brought my 1974 TX650A back from the grave. I have spent a good deal of $$ and alot of time on it. Just painted it and working on electrical, I will post pics soon, Apr 10, 2021 2:14:13 GMT -5
louisvan: trix13 - I had a problem with my 1975 SX650. When I got to highway speeds, the engine lost power. The problem was in the connectors. At a certain vibration and the wind pushing on the wiring loom, the connector lost continuity. A bad crimp to the wire. May 20, 2021 1:19:09 GMT -5